Do I need the waist-high version? (backers outside of North America only)